Using tables for organisation and display in Word 2013

If you use Microsoft Word, then it is likely that at some point you will need to create a table.

There are two ways to use Word’s table features. The most common is as a method of displaying data. The other is as a layout mechanism for arranging content on a page.

Using tables to display data

If you need to present information in rows and columns, then a table is the obvious choice. Even if it is only a few rows or columns, tables are easier to use than tabs, and less likely to go wrong.

Using Quick Tables

Word provides a gallery of Quick Tables. These are ready-made tables you can use as a starting point. They are fairly specialised – calendars, for example – but there may be something that suits. Click on the Insert tab, and on Table, then point to Quick Tables. Once you have inserted the table, you can edit it using the features covered below.

Creating a simple table

If all you want is a simple table, the easiest method is to click on Table and drag your cursor over the grid. This gives you a basic grid you can format as you wish.

If you want to create a table that is bigger than ten columns by eight rows, use the Insert Table option.

The Draw Table option is really only useful if you are creating a table with a very specific structure, since you have to manually draw in the rows and columns.

Resizing and positioning a table

The table will automatically size itself to fit the page width. To resize it quickly, move your cursor to the bottom right corner to display the resize handle, then just drag it. To resize proportionally, hold down [Shift] and drag. Note that this does not resize the content as well.
By default, tables are positioned at the left margin. To change this, click on the **Table Tools Layout** tab, and in the **Table** group, click on **Properties**. Choose an **Alignment** setting from the **Table** tab. Note that it is possible to set text to wrap around a table. This, however, turns the table into a ‘floating’ object which can make it difficult to position accurately.

### Formatting a table

The **Table Tools Design** tab includes a gallery of **Table Styles**. You can use the **Table Style Options** group to change the range of styles you see.

Click to turn options on or off; for example, you can have a differently-formatted header row, or banded shading on rows or columns. The gallery will change to display styles that include the options you have selected.

You can also use these options to change the formatting of a table after the style has been applied. Note, however, that the result will depend on the style. For example, you may find choosing banded rows or columns doesn’t give you the effect you are looking for. In these cases, you will have to choose another style from the gallery.

> **Note:** The colours in the table styles gallery are dependent on the document’s *theme*. By default, new documents use the Office theme. To select another, click on the **Design** tab and on **Themes**. The theme will also affect the fonts used.

You can make a table style your default, so that whenever you insert a new table, the style is applied automatically. Right-click on the style in the gallery and select **Set as Default**. Choose whether to set it for the current document or all documents. (Normal.dotm is the template Word uses whenever you create a new blank document.)

### Applying borders and shading

The built-in styles may not give you exactly what you want. You can apply additional formatting by using the **Borders** and **Shading** options.

To apply a border, first select the cells, rows, columns or the whole table (you can do this with the mouse, or by using **Select** on the **Table Tools Layout** tab).

> **Tip:** To select an entire table quickly, move your cursor to the top right of the table and click on the **Move** icon 🔄.
On the **Table Tools Design** tab, choose a **Line Style**, **Line Weight** and **Pen Color** from the **Borders** group. Click the down arrow at **Borders** and choose a border location. If you are going to choose **No Border**, check that **View Gridlines** (bottom of the **Borders** menu) is selected; otherwise you won’t be able to see where the cells are.

To apply borders to specific cells, an additional tool you can use is the **Border Painter**. First, choose the formatting or select a **Border Style** to activate the **Border Painter**, then click on a border to apply it. To apply the formatting to several cells, click and drag. Click on **Border Painter** to deactivate it.

If you have created a custom border, you can use the **Border Sampler** to apply it to any table in your document. Click on **Border Style** and select **Border Sampler**. Click on the border with the eyedropper tool to activate the **Border Painter**.

To apply shading, select the cells, rows, columns or the table, click on **Shading** and choose a colour.

**Saving a table design as a Quick Table**

If you have spent time designing and structuring a table, you can save it to use again. Don’t enter any content unless you want it to be part of the design.

Select the table, then click on the **Insert** tab and on **Table**. Point to **Quick Tables** and select **Save Selection to Quick Tables Gallery** from the menu at the bottom to open the **Create New Building Block** dialog box.

Give the table a name – make this short and unique, i.e. if you are saving several tables, avoid calling them ‘table1’, ‘table2’, etc. Enter a description if you wish, but leave all other options as they are. The table is saved in a template called Building Blocks.dotx.

When you close Word, you will see a prompt to save the changes. Click **Save**. The table is saved as a ‘building block’ that you can use in other documents.

One way to insert your table is to click on **Insert** and **Table**, then **Quick Tables**. Scroll to the bottom of the list and click on your design. If you have given your table a unique name, there is a quicker way. Click where the table is to appear, type the first few letters of the name and press **[F3]**.

To delete your table from the Quick Tables gallery, click on the **Insert** tab, then in the **Text** group, click **Explore Quick Parts** and select **Building Blocks Organizer**.

Click on your table in the list and click **Delete**. To make it easier to find, click on **Name** to sort the list alphabetically.

**IS Skills Development**
Note that when you insert a quick table you have created, it will appear exactly as you saved it, including the number of rows and columns. As an alternative, you can modify a table style.

**Modifying a table style**

You can modify a built-in table style so that you can apply your customised formatting to other tables.

First, create a table and apply a style so that you will be able to see the effect of your changes. Right-click on the style in the Table Styles gallery and select **Modify Table Style** to display the **Modify Style** dialog box.

To format a specific element, select an option from **Apply formatting to** – the default is **Whole table**.

You can set some formatting options from this dialog box, but for the full range, click on the **Format** button.

Note that if you want to change the borders, and will be using banded rows or columns, you will need to apply the border formatting to the banded row and column elements separately.

You can set the header row to repeat as part of the design. In **Apply formatting to**, choose **Header row**. Click on **Format** and select **Table Properties**. On the **Row** tab, select **Repeat as header row at the top of each page**.

The changes you make to the style apply to the current document only. If you want to be able to use the modified style in new documents, select **New documents based on this template**.

**Changing the layout**

The **Table Tools Layout** tab includes options for manipulating a table.

**Deleting cells, columns or rows**

Click in the part of the table you want to remove, and in the **Rows & Columns** group, click **Delete** and select an option.
Inserting rows and columns
There is now a quick way to insert rows and columns. Hover over the right or top border of the table to display the control, then click the plus sign.

<table>
<thead>
<tr>
<th>Course type</th>
<th>Course Name</th>
<th>No. of courses</th>
<th>Total bookings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Taught course</td>
<td>BI Suite Advanced</td>
<td>3</td>
<td>29</td>
</tr>
<tr>
<td></td>
<td>Getting Started with BI Suite</td>
<td>1</td>
<td>11</td>
</tr>
<tr>
<td></td>
<td>Introduction to NVivo</td>
<td>1</td>
<td>15</td>
</tr>
</tbody>
</table>

If you want several rows or columns, select a group of rows or columns in the table then click the plus sign.

Alternatively, in the **Rows & Columns** group, click in the table and choose an option to insert a row above or below, or a column to the right or left.

Adjusting row or column sizes
The easiest way is to move your cursor to the column or row border until you see the resize cursor \( \downarrow \), then drag. For columns, you can also drag the markers on the ruler \( 3 \cdot 4 \cdot 1 \). (If you can’t see the ruler, click **View** and select **Ruler**.)

**Tip:** If you try to drag a border a small amount you may find that it jumps further than you want. Hold down the [Alt] key while you drag; this allows you to move it more precisely.

If you need a row or column to be an exact size, you can set a specific **Height** and **Width** in the **Cell Size** group. (To return a row to its default size, click on **Properties** and on the **Row** tab, deselect **Specify height**.)

To resize a single column to fit the contents, move your cursor to the right-hand border and double-click. To resize all the columns at once, click anywhere in the table, then click on **AutoFit** and select **AutoFit Contents**.

To adjust the table width to fit the page exactly, click on **AutoFit** and select **AutoFit Window**. If you have resized a column manually, this size will be retained; other columns will be resized evenly. This is a great option to try if you have pasted data from Excel, and the table has gone over the edge of the page.

To size rows or columns evenly, select them, and then click on **Distribute Rows** or **Distribute Columns**.

Moving rows and columns
If you want to move a row or a column, there is quick way to do it. Select the row or column, move your cursor into it (but don’t click), hold down the mouse button and drag to the new position. You’ll see a positioning guide \( \downarrow \). You can select several rows or columns to move together.
Repeating header rows

If your table breaks across pages, you can force your header row to repeat on every page. Click in the row and on Repeat Header Rows on the Table Tools Layout tab. If you want more than one row as a header, select the rows first.

Aligning and re-orientating text

In the Alignment group, choose an option to align text within a cell, vertically and horizontally. You can also set the amount of space between the cell border and its contents through Cell Margins. This setting applies to the entire table. See the section Controlling the positioning of objects on page 10 for how to set margins for an individual cell.

You can change the direction of text in a cell – the header row, for example. Select the cells and click on Text Direction repeatedly to cycle through the layout options.

<table>
<thead>
<tr>
<th>Course Type</th>
<th>No. of courses</th>
<th>Attendees</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scheduled</td>
<td>18</td>
<td>166</td>
</tr>
<tr>
<td>On-demand</td>
<td>2</td>
<td>35</td>
</tr>
<tr>
<td>Total</td>
<td>33</td>
<td>381</td>
</tr>
</tbody>
</table>

Unfortunately, unlike Excel’s Orientation feature, you can’t rotate text in a table diagonally.

Splitting and merging cells

You can split one cell into several, or combine cells together, by selecting Split Cells or Merge Cells. Note that once you have merged or split cells it becomes harder to insert or delete rows and columns without doing a lot of reformatting. Leave the merging and splitting until you are sure your table is the size you want.

Tip: An easy way to split or merge cells is to use the Draw Table and Eraser options in the Draw group on the Table Tools Layout tab. To split a cell, click Draw Table and draw a line through it. Click Draw Table again or press [Esc] to stop drawing. To merge cells, click Eraser and drag over the line. Click Eraser again or press [Esc] to finish.

Sorting data

To sort your table, first select it, then on the Table Tools Layout tab, click Sort. Choose the column to sort by and whether it’s to be in ascending or descending order. You can also set a second level sort in Then by if you wish. Under My list has select Header row or No header row. Note that if you have used Repeat Header Rows, this option will be greyed out.
Using formulas

You can create simple formulas in a Word table. Click in the cell and on Formula on the Table Tools Layout tab. If figures have been entered, Word will insert the formula =SUM and a direction (ABOVE, BELOW, LEFT and RIGHT) automatically. Make sure there is a value in each of the cells, since Word will stop the calculation at cells that are blank or contain text.

To choose a different function, click on the down arrow at Paste function.

You can create a more complex formula by typing in cell references in the same way as in Excel, for example, =SUM(A1:A20).

Note that if you change the values in a table, the formula results do not update automatically. To update, the quickest method is to select the table and press [F9].

Formatting text

When you create a table, Word appears to be using the default paragraph style, called Normal, to format the text font and paragraph settings (you’ll see it highlighted in the Styles gallery on the Home tab). However the formatting that is actually applied comes from the table style rather than the paragraph style; therefore you will find that some attributes, such as spacing, are not the same as the text in the body of the document.

To see the formatting, right-click on the table style in the Table Styles gallery on the Table Tools Design tab and select Modify Table Style. For paragraph settings, click on Format and select Paragraph. You can also modify any other attributes – font type and size, for example.

If you change the settings in the Modify Table Style dialog box, they will be applied whenever you select the table style. You can choose to apply the changes to the current document or all documents.

If you just want to modify the settings for a single table, select the table, then on the Home tab, make any font changes, or for paragraph attributes, click the Paragraph dialog box launcher.

Controlling page breaks

If your table flows over several pages, you can control how and where the content breaks. There are two aspects to this:

- Controlling where content breaks in a row
- Controlling where content breaks on a page

Controlling where content breaks in a row

By default, the content in a table row will break across pages. This means that you could have some lines on one page and some on another, making it difficult to read. You can prevent this happening for the entire table or for individual rows.
Select the table or rows. Click on the **Table Tools Layout** tab, and in the **Table** group, click on **Properties**. Click on the **Row** tab, and deselect **Allow row to break across pages**. The content in a row will stay together.

**Controlling where the content breaks on a page**

Although it is possible to use a manual page break to split a table at a specific point, repeating header rows will not be carried forward since you now have two separate tables. Note however that if you have used a table style with a header row (**Table Style Options**), the header row **formatting** will be applied to the first row of the new table.

To keep your repeating header, click in the first cell of the row to be moved to the next page, then on the **Home** tab, click on the **Paragraph** dialog box launcher. Click on the **Line and Page Breaks** tab and select **Page break before**.

![Tip: If you want to prevent a table splitting across pages at all, select the table, and on the **Home** tab, click on the **Paragraph** dialog box launcher. On the **Line and Page Breaks** tab, select **Keep with next**. (If the table is more than a page in length, Word will split it across pages regardless.)

---

**Inserting an Excel spreadsheet**

If you are performing calculations, normal practice is to create a worksheet in Excel then copy and paste the data into your Word document.

However, if you don’t need to have a separate Excel file, you can create an Excel ‘object’ directly in the Word file.

Click where you want the Excel data to appear, and on the **Insert** tab, click on **Table**, then choose **Excel Spreadsheet**. The Ribbon will change to display the Excel tabs, allowing you to work as you would in Excel.

To finish, click away from the object. To edit the data, double-click on the object to display the Excel commands again.

**Creating a chart from a table**

If your table contains figures, you can create a chart without having to insert a chart and re-enter the data.

Ideally, your table should have a header row and/or a first column (which form the chart labels), but it will work without them.
Select the table (or the rows and columns to be charted), then on the Insert tab click on Object and Object again. In the Object dialog box, choose Microsoft Graph Chart. The chart appears directly below the table.

You can use the menu commands to format the chart. Note that although you can edit the datasheet, the original table will not be updated.

Click away from the chart object to return to the normal Word Ribbon.

Tip: To convert the chart to an Office 2013 format, click away to close the datasheet then drag it into a blank paragraph (to make it easier, click on Show/Hide on the Home tab so that you can see the formatting marks). Release the mouse when a positioning marker appears. Click on the chart to display the Chart Tools tabs.

Using tables to organise content

Although tables are normally used for arranging information in columns and rows, they can also help you to place content on a page. Images, for example, can be difficult to position accurately, particularly when combined with text.

A table is essentially a container; you can use it to align text and images, and you can even nest one table inside another to handle complex layouts, as in the example below.

If you are using a table for placement, remove any borders. If you wish, you can apply borders to individual rows, columns or cells to create different effects.
Controlling the positioning of objects

For more exact placement of objects within a table, you can set alignment and margins for individual cells.

As well as selecting an option from the Alignment group on the Table Tools Layout tab, you can also control the amount of space between the cell border and the content.

Click on Cell Margins to set the space for the entire table. To set the margins for individual cells, select the cells and click on Properties on the Table Tools Layout tab. On the Cells tab, click on Options to display the Cell Options dialog box.

Deselect Same as the whole table and change the margin settings.

Note that this dialog box includes a Fit text option. This forces text to fit into a cell without allowing the cell to resize; Word will compress the text horizontally. This can be useful if you need tight control over the layout of a page, but can make text difficult to read – changing the font size often gives better results.

You can also control positioning by inserting a tab character within a cell. Click in the cell, hold down [Ctrl] and press [Tab]. Word will insert a tab at the default tab settings. To place tabs exactly, display the ruler (click the View tab and select Ruler), then click on the ruler to insert a tab at that location. To insert a different type of tab, first click the selector at the top left repeatedly to rotate through to the tab you want, and then click on the ruler.

You can create complex layouts by merging and splitting cells. You can also change the column width of individual cells in a row. To do this, select the whole row and then drag the boundary of the cell you want to resize. The column width of the other cells in the row will not change.

Using nested tables

‘Nesting’ a table means creating one table inside another. Simply click in a cell in an existing table and insert another table.

To make the nested table fit the cell exactly, select it, and on the Table Tools Layout tab, click on AutoFit and select AutoFit to Window. The cell is the nested table’s ‘window’.

Tip: To add content to the host cell (as opposed to the nested table), click at the end of the last cell in the nested table and press the right arrow on the keyboard twice.
Converting text to a table

If you have used tabbed text, you can easily convert this to a table. Select the text, click Insert and Table, then click Convert Text to Table.

Word will enter the number of rows and columns automatically. Make sure Separate Text at is set to Tabs.

Although you can convert text if you haven’t used tabs, the table structure may need some work afterwards.

You can also convert table text to plain text. Select the table, then on the Table Tools Layout tab click Convert to Text in the Data group. Word will insert tabs automatically.

Resources

For more information on Word features and functions, see the Working with Text section on our Documents Catalogue at www.ed.ac.uk/is/skills/documents-catalogue

For information on our training courses, see www.ed.ac.uk/is/skills