Creating tables of contents and figures in Word 2013

This note shows you how to create a table of contents or a table of figures in just a few clicks of the mouse.

Tables of contents and figures the easy way

The key to creating a contents page quickly and easily is to use Word’s built-in Heading styles, i.e. Heading 1, Heading 2, etc. Once you have applied the styles, you can use the Table of Contents option to do all the hard work for you.

If you don’t know how to use styles, see: Formatting with styles in Word, available on our Documents Catalogue at www.ed.ac.uk/is/skills/documents-catalogue

If you have images, diagrams or tables in your document, you can list them in a table of figures. Use Word’s Insert Caption function to create the captions; then the Insert Table of Figures option will allow you to build the table automatically.

Creating a basic table of contents

The first step is to apply the Heading styles to the text that you want to include in the table of contents.

Once you have applied the styles, move to where the table of contents is to appear, then click on the References tab and on Table of Contents in the Table of Contents group.

Using the built-in layouts

Word displays a gallery of built-in layouts. You can choose from Automatic Table 1 or Automatic Table 2. Word creates a table of contents with three levels using the text formatted as Heading 1, Heading 2 and Heading 3.

To make changes to the table layout, click in the table, and on Table of Contents, then choose Custom Table of Contents from the menu at the bottom to display the Table of Contents dialog box.
Note that Word uses the style **TOC Heading** to format the table of contents heading. If you don’t like how it looks, you can modify the style.

**Using the dialog box**

The **Table of Contents** dialog box allows you to change the appearance and content of your table. You can use it to modify an existing automatic table layout, or create a table of contents ‘from scratch’.

The **Print Preview** box shows you how your table of contents will look.

By default, the page numbers are right-aligned, and have a dot as a tab leader.

Although there are a number of **Formats** to choose from, it is safer to leave this as **From template** so that Word will use its built-in Table of Contents (TOC) styles.

The **Show levels** option is set to three by default; that is, the text formatted as Heading 1, Heading 2 and Heading 3 will appear in the table of contents. You can select more or fewer levels.

**Tip:** If you have typed in a heading for your table of contents, don’t apply a built-in Heading style to the text – you don’t want it appearing in the contents list! Format the text manually, or create a new custom style. If you used one of the built-in layouts, the style **TOC Heading** is applied automatically.

**Updating a table of contents**

It is vital to remember that Word does not update a table of contents dynamically. If you make changes to your document, perhaps to add or delete a section, or alter the text of a heading, you must update the table of contents manually.

To do this, click anywhere in the table, then click on the **References** tab and on **Update Table** in the **Table of Contents** group. If you have used an Automatic Table layout, you can click on **Update Table** on the tab at the top of the table frame.

A useful shortcut is to press the [F9] key.
At the **Update Table of Contents** dialog box, you can choose to update the page numbers only, or the entire table. It is always a good idea to choose **Update entire table**.

Click **OK** to replace the table of contents.

Always update your contents before saving or printing your document to make sure any changes are included.

**Tip:** You can set up Word to always update tables of contents when you print. Click on the **File** tab and select **Options**. Select **Display**, and under **Printing options**, choose **Update fields before printing**.

### Customising a table of contents

Word’s basic table of contents might not contain all the entries you need, or look the way you would like. You can modify both the content and the appearance.

#### Modifying the content

**Including additional styles**

By default, Word only uses text formatted with the built-in Heading styles to build a table of contents. However, if you have used other styles, or have created custom styles, you can include these as well.

Click in the table and on **Table of Contents** on the **References** tab, and then choose **Custom Table of Contents**. Click the **Options** button to display the **Table of Contents Options** dialog box.

Under **Build table of contents from**, **Styles** is selected by default, and all the styles in the document appear in the **Available styles** list.

The **TOC level** box indicates the level at which the text formatted with the style will appear in the table.

Locate your additional style and enter the level you want it to appear at.

In the example below, the styles Appendix 1 and Appendix 2 are new styles, which will appear at the same level as Heading 1 and Heading 2:
Entering the TOC level means that the table of contents will include all text formatted with the styles Appendix 1 and Appendix 2 as well as Heading 1 and Heading 2.

Including additional text

Although you will see an Add Text option in the Table of Contents group on the References tab, this works by applying a Heading style to the text. If you don’t want the text formatted as a heading, there are alternative methods.

If the text is a full paragraph, the easy option is to assign an Outline level to the paragraph. To do this, click in the paragraph, and on the Home tab, click on the dialog box launcher in the Paragraph group. On the Indents and Spacing tab, click on the down arrow at Outline level and select the level the text is to appear at in the table of contents. This does not apply any formatting to the text.

Next, click in your table of contents, and on the References tab, click on Table of Contents and choose Insert Table of Contents. Click on the Options button, make sure that Outline levels is selected, then click OK and OK again. When you replace the table of contents, your paragraph will appear.

If you want a section of text only within a paragraph to appear, you could create a table of contents (TC) field, but it is easier to use a linked style.

Create a new linked style with the same attributes as the rest of the paragraph then apply it to the section of text. When you create the table of contents, only the text formatted with the linked style will appear. See the Tips and tricks section below on displaying part of a heading or caption for more information. For instructions on creating styles, see the note Formatting with Styles in Word.

Modifying the appearance

To change how the table of contents looks – font type, size, indentation etc. – click in the table and on Table of Contents on the References tab, then choose Custom Table of Contents again.

In the Table of Contents dialog box, click the Modify button to display the Style dialog box.
Word includes nine built-in table of contents styles (TOC 1 to TOC 9) corresponding to the nine heading levels. The symbol ▶ indicates the style of the paragraph your cursor was on when you opened the Table of Contents dialog box.

Click on the TOC style you want to change and on the Modify button to display the Modify Style dialog box.

Make your formatting changes and click OK to return to the Style dialog box. Choose another TOC style to modify if you wish.

Click OK to finish and OK again to replace the table of contents.

---

**Tip:** You can modify the TOC styles from the Styles pane as well as from the Table of Contents dialog box. Click just in front of the page number in the table of contents so that the style name is highlighted in the pane. Move your cursor to the style, click on the down arrow and select Modify.

This is useful if you have modified the table Options to include additional styles since it does not force it to rebuild. Rebuilding returns Options settings to the default, therefore you will have to make any changes again before exiting the Table of Contents dialog box.

---

**Creating a table of figures**

If you have pictures, diagrams or tables in your document, it is useful to list them in a table of figures. This is done by creating a caption for each item. However, to build the list automatically, the caption should be created using Word’s Caption function, and not simply typed in manually.

To create a caption, click on the image or table and on the References tab. Click Insert Caption in the Captions group to display the Caption dialog box.

At Label, select the appropriate label for the object. You can choose from Equation, Figure or Table, or you can create your own through New Label.

In the Caption box, click after the number and type any descriptive text you wish.

Although you can choose a Position for the caption, it is a good idea to leave this at the default setting. See tip below.
To insert the table of figures, click where the table is to appear and on the References tab, click Insert Table of Figures in the Captions group.

At Caption label, select the label and click OK.

As with the table of contents, you can use Modify to change the appearance of the table.

If you have used more than one label, repeat to create a table for each one.

Tips and tricks

Displaying part of a heading or a caption only in a table of contents

If you have a long heading or caption, you might only want part of it to appear in the table of contents. This is referred to as a ‘lead-in’ header. You can achieve this by using Word’s linked style feature. A linked style can be used as either a paragraph or a character style.

First, check whether the style you want to use is a linked style, indicated by ✶ next to the style name in the Styles pane. Caption, for example, is not a linked style by default.

If the style is not linked, move to the style name in the pane, click on the down arrow and select Modify. In Style type, choose Linked (paragraph and character) and click OK.

Tip: For an image, make sure you select it before you insert the caption, and that the Position setting is Below selected item. If the image’s wrap setting is In Line with Text (Layout Options button), Word will apply the paragraph attribute Keep with next automatically when the caption is inserted. This means that the image and its caption will not get separated and end up on different pages.

For a table, the Keep with next attribute is only applied automatically if you select Above selected item. If you do want to put the caption below the table, select the final row, click on the dialog box launcher in the Paragraph group, and on the Line and Page Breaks tab, select Keep with next. This will stop the last row of the table and the caption splitting across pages.

Tip: For an image, make sure you select it before you insert the caption, and that the Position setting is Below selected item. If the image’s wrap setting is In Line with Text (Layout Options button), Word will apply the paragraph attribute Keep with next automatically when the caption is inserted. This means that the image and its caption will not get separated and end up on different pages.

For a table, the Keep with next attribute is only applied automatically if you select Above selected item. If you do want to put the caption below the table, select the final row, click on the dialog box launcher in the Paragraph group, and on the Line and Page Breaks tab, select Keep with next. This will stop the last row of the table and the caption splitting across pages.

To insert the table of figures, click where the table is to appear and on the References tab, click Insert Table of Figures in the Captions group.

At Caption label, select the label and click OK.

As with the table of contents, you can use Modify to change the appearance of the table.

If you have used more than one label, repeat to create a table for each one.

Tips and tricks

Displaying part of a heading or a caption only in a table of contents

If you have a long heading or caption, you might only want part of it to appear in the table of contents. This is referred to as a ‘lead-in’ header. You can achieve this by using Word’s linked style feature. A linked style can be used as either a paragraph or a character style.

First, check whether the style you want to use is a linked style, indicated by ✶ next to the style name in the Styles pane. Caption, for example, is not a linked style by default.

If the style is not linked, move to the style name in the pane, click on the down arrow and select Modify. In Style type, choose Linked (paragraph and character) and click OK.

Tip: For an image, make sure you select it before you insert the caption, and that the Position setting is Below selected item. If the image’s wrap setting is In Line with Text (Layout Options button), Word will apply the paragraph attribute Keep with next automatically when the caption is inserted. This means that the image and its caption will not get separated and end up on different pages.

For a table, the Keep with next attribute is only applied automatically if you select Above selected item. If you do want to put the caption below the table, select the final row, click on the dialog box launcher in the Paragraph group, and on the Line and Page Breaks tab, select Keep with next. This will stop the last row of the table and the caption splitting across pages.

To insert the table of figures, click where the table is to appear and on the References tab, click Insert Table of Figures in the Captions group.

At Caption label, select the label and click OK.

As with the table of contents, you can use Modify to change the appearance of the table.

If you have used more than one label, repeat to create a table for each one.

Tips and tricks

Displaying part of a heading or a caption only in a table of contents

If you have a long heading or caption, you might only want part of it to appear in the table of contents. This is referred to as a ‘lead-in’ header. You can achieve this by using Word’s linked style feature. A linked style can be used as either a paragraph or a character style.

First, check whether the style you want to use is a linked style, indicated by ✶ next to the style name in the Styles pane. Caption, for example, is not a linked style by default.

If the style is not linked, move to the style name in the pane, click on the down arrow and select Modify. In Style type, choose Linked (paragraph and character) and click OK.
If you can’t see the Caption style in the Styles pane, click on Options and in Select styles to show, choose All styles and click OK.

If the heading or caption has already been formatted, click in the paragraph and select Clear All in the Styles pane. You can also click on the More button at the Styles gallery and choose Clear Formatting.

Select the part of the heading or caption that you want to appear in the table of contents or table of figures and apply the Heading or Caption style. Manually format the rest of the heading or caption to match the style attributes.

For a table of contents, follow the instructions to create or update a table of contents in the sections above. Only the text formatted with the linked style will appear.

For a table of figures, there is an additional step. After adding all your captions, click on the References tab and on Insert Table of Figures in the Captions group.

At Caption label, select a label. Now click on the Options button to display the Table of Figures Options dialog box.

Under Build table of figures from, click the Style box to select it and make sure that the style name is Caption.

Click OK to finish.

Note that this method creates a single table for all caption labels – you cannot create separate table. If you do want separate tables, use the Style Separator method as described in the Note below.

Note: Linked styles do not work if you select text in a numbered heading. If you want to create ‘lead-in’ text on a numbered heading, you must use the Style Separator. First, add the Style Separator tool to the Quick Access Toolbar:

Click on the Customize Quick Access Toolbar button , and choose More Commands. In Choose commands from, select Commands Not in the Ribbon. Scroll to Style Separator, click Add and OK.

Type the first part of the heading and apply the Heading style. Click at the end of the text and on the Style Separator icon on the Quick Access Toolbar, then type the rest of the heading text. Format the text in the same way as the Heading style.
Creating a table of contents without top level page numbers

In the Table of Contents dialog box, you can stop page numbers appearing at all levels by deselecting the Show page numbers check box. However, if you only want to stop the page numbers for a single level – a chapter title, for example – you have to edit the table of contents field code directly.

First, insert your table of contents with the Show page numbers box deselected.

To see the code, click anywhere in the table of contents, hold down the [Alt] key and press [F9]. For a table of contents with three levels, the code will look like this:

{ TOC \o “1-3” \n \h \z \u }  

TOC is the field name for table of contents. The field includes instructions ('switches'), shown as \ and a letter. The instruction to omit page numbers is \n.

To omit page numbers for a specific level, you need to enter a level range after the \n switch. To omit numbers for level 1, for example, click in the field after \n and type the range “1-1”. (Even if it is a single level, you still need to enter a range.)

{ TOC \o “1-3” \n “1-1” \h \z \u }  

Hold down [Alt] and press [F9] again to see the table of contents text, and then press [F9] to update.

Note that if you make any further changes to the table of contents options which will force it to be replaced, you will need to edit the field code again.

Resources

For more information on Word features and functions, see the Working with Text section on our Documents Catalogue at www.ed.ac.uk/is/skills/documents-catalogue.

For information on our training courses, see www.ed.ac.uk/is/skills.